Google Fiber Connection Dropping

So after months working off of my phone’s hotspot, Google Fiber was finally turned on in my building. It was quite a relief as T-mobile throttles wireless hotspots. Before Fiber it was like being on dial-up again.

I’m on the Fiber 1000 plan, and it has mostly been great. However, I have noticed that my Google Fiber WiFi connection is frequently dropping. It’s only gone for a few minutes at a time, but it is enough to be incredibly annoying. I don’t want to have to manually switch to LTE when I’m browsing reddit at 6am.

Anyways, thoughts on what is happening here? My network box is located inside a metal IKEA locker. Could that be causing some sort of interference?

FWIW, I’m in Atlanta.

The closest thing I’ve found is a discussion on reddit about iPhones dropping wifi connections on Google Fiber. The issue isn’t limited to my phone, but I thought the proposed solution was interesting.

ikilldkenny
Split the networks and manually set the 5ghz channel to 36

One thing that’s interesting about Google Fiber. The network box contains both 2.4 GHz and 5 GHz bands and that it automatically determines, which band it connects devices to.

Could the issue be related to that feature?

Anyways, I’ve decided to split my WiFi network and see what happens. You can do this by going to fiber.google.com and navigating to the Network page. Here you’ll see something like this. Just click Advanced and then the Wi-Fi tab.

As you can see above. I’ve selected Other and named the a 5 GHz band separately.

I am less certain about changing the channel settings. For now I’ve left it as automatic. If splitting the band doesn’t work I’ll try that next.

It’s only been a day, but since I’ve done this my Google Fiber connection hasn’t dropped. I’ll give it a few more before marking this as a correct solution.

Sadly, it doesn’t appear splitting the bands has resolved the issue.

My phone shows that it is connected to the internet the entire time. But most websites and apps needing WiFi won’t load. When I am able to do a speed test I get 200 to 300 Mbps, which is what I would expect for a wireless device.

This whole thing is really bizarre. It seems that this is only an issue when I’m at my bed, which is maybe 30 feet away with nothing obstructing it other than that metal locker. It seems to me the steps to try are:

  • Change the 5 GHz band from automatic to channel 36 like mentioned in the above post
  • Move the Network Box out of the locker

If none of those options work, I’ll probably need to reach out to Google. I will say Google’s Troubleshoot Your Network Connection quiz isn’t particularly helpful as the devices listed are Mac and Windows—they don’t cover iOS or Android phones.

OK, I think this problem is finally solved. If you are having issues with Google Fiber try this:

  • Split the WiFi bands into 2.4 GHZ and 5 GHz
  • Set the 5 GHz channel from automatic to 36 GHz

I have no idea why this works, but it seems to have solved my issue with the Google Fiber connection dropping.